SECURITY INFORMATION: CRITICAL SECURITY GAPS - MOZILLA FIREFOX

16. April 2020

The OpenSource WebBrowser Mozilla Firefox contains a critical vulnerability. A remote anonymous attacker could exploit multiple vulnerabilities in Mozilla Firefox and Mozilla Firefox ESR to execute arbitrary code with user privileges.

We strongly recommend updating Firefox to a secure version (Firefox version 75 and Firefox ESR version 68.7). Also affected is the TOR web browser, which should be updated to version 9.0.9 if possible.

Please do not hesitate to contact us if you have any questions

thumb patrick hertig csoPatrick Hertig | Chief Information Security Officer
patrick.hertig@itpoint.ch | +41 31 959 35 10

Blog